BarDIMM Pro for HP Futuresmart printers

RELEASE NOTES AND FAQ

IMPORTANT:

If a “DEMO” watermark appear on the pages it indicates the BarDIMM Pro licensing system in the embedded softare can’t communicate with the BarDIMM Pro USB stick. This can be due to one of the following reasons:

  • You have upgraded the printer firmware without updating BarDIMM Pro
  • You need to update the BarDIMM Pro solution to the latest version, verify you are under support contract with us for BarDIMM Pro and contact us through the Celiveo support center
    or
  • The BarDIMM Pro USB stick is defective and needs to be replaced. Verify you are under support contract with us for BarDIMM Pro and contact us through the Celiveo support center

RELEASE NOTES

2nd of September 2021
Firmware 5.2 compatibility
Good news, with BarDIMM Pro 8.4A4M released the 2nd of September 2021, the following printer models can now run HP Futuresmart 5.2 firmware together with BarDIMM Pro:
LJ Enterprise M406dn/M407dn
LJ Enterprise MFP M430f/M431f
CLJ Enterprise M455dn
CLJ Enterprise MFP M480f
LJ Managed MFP E42540f
CLJ Managed E45028dn
CLJ Managed MFP E47528f

 

20th of August 2021
Firmware 5.2 compatibility
The following printer models need to remain with firmware Futuresmart 5.1.x:
LJ Enterprise M406dn/M407dn
LJ Enterprise MFP M430f/M431f
CLJ Enterprise M455dn
CLJ Enterprise MFP M480f
LJ Managed MFP E42540f
CLJ Managed E45028dn
CLJ Managed MFP E47528f

 

20th of April 2021
Crash 49.38.13 with HP Futuresmart firmware releases between 4.11.0.2 and Futuresmart 5.1
Some random crash 49.38.13 may happen when the BarDIMM Pro is installed in the printer equipped with that firmware and other solutions.
The defect is fixed in HP Futuresmart 5.2 firmware.
If your HP printer does not have Futuresmart 5.2 available, we recommend you downgrade to Futuresmart 4.11.0.1.

 

20th of January 2021
New HP Printers release from January 2021 need a new generation BarDIMM Pro stick
From now on there are now 2 categories of HP Futuresmart printers:
Classic: that’s all hp Futuresmart printers released before 2021, they support Futuresmart 4 (FS4) and some will support Futuresmart5 (FS5)
Modern: that’s all Futuresmart printers released after Jan 1, 2021, they come with FS5 and don’t support FS4.

Classic and Modern printers are binary-incompatible (like software for Windows and Mac are not compatible).
Plugging a current BarDIMM Print USB stick in one of those new printers won’t work.
We have developed a new BarDIMM Pro for those printers.

What happens to Futuresmart Classic printers supporting FS4?
Most will get a Futuresmart 5 update, 100% compatible with FS4

How to use BarDIMM on the new HP Futuresmart Modern printers not supporting FS4?
The new Futuresmart Modern printers will use the new BarDIMM Pro white stick, it has a new part number: JM30100Z.
All the new Futuresmart Modern printers  supporting embedded BarDIMM Pro are listed in the HP printers support table.

 

3rd of February 2020, updated 20th of January, 2021
Compatibility with HP Futuresmart 4.9.0.1 and 4.10.0 firmware
HP Futuresmart firmware 4.9.x and 4.10.x being even more recent than 4.7.1, they require BarDIMM Pro version 8.4A1 or newer.
Clients under maintenance and support contract can request the upgrade from our support, through the contact form.

HP Futuresmart firmware 4.9.0.1 and 4.10.0.1 have a defect that  load multiple times embedded solutions instead of just once.
This results in corrupted print job data and a printer crash after a few pages.
This problem and the solution can easily be diagnosed by checking the printer configuration page,
where repeated lines about “IOF 254 Requested for BarDIMM Pro” appear.

Solution: upgrade the firmware greater than 4.10.0.1.

Update: it has been reported in a few cases the issue may also appear on HP printers with firmware greater than 4.10.0.1.
Apparently a partial clean of the printer fixes the issue.
https://support.hp.com/ca-en/document/c05079497#CLEAN

 

2nd of January 2019
Compatibility with HP Futuresmart 4.7.1 and newer
Firmware 4.7.1 introduces a new security where print solution packages need to comply with a new code signature mechanism to be installed.
BarDIMM Pro 8.4A1 and newer versions include that new mechanism.
If BarDIMM Pro was installed prior to the printer upgrade to HP Futuresmart 4.7.1 then you don’t need to update BarDIMM as the new mechanism controls the installation of the solution.
For all other cases you need to upgrade the BarDIMM Pro USB stick to version 8.4A1, Clients under maintenance and support contract can request the new version from our support, through the contact form.

 

18th of July, 2018
Compatibility with HP Futuresmart 4.6.0.x , 4.6.1 and 4.6.2
If the HP printer is upgraded with firmware 4.6.0.1, 4.6.1 or 4.6.2 and is equipped with BarDIMM Pro, an Error 49.38.02 happens and the printer crashes.
This has been determined as being a defect in those printer firmware code, a fix will be present in HP Futuresmart 4.6.3 to be released within a few weeks.
Clients who absolutely need to upgrade their firmware and who are under valid BarDIMM support contract can contact Celiveo  to receive a workaround BarDIMM solution file. That version
8.2C2-20180717 with workaround lacks the support for some early HP Futuresmart printers released between 2010 and 2013, but no functional feature is lacking.

 

24th of January 2018
Compatibility with HP Futuresmart 4.x printer base firmware
HP is releasing updates to its Futuresmart 4 printer firmware for new and some older printers/MFPs.
That firmware requires some changes in embedded applications and a new version of BarDIMM Pro has been released early this month.
That’s BarDIMM Pro 8.2 20171117, available to clients under support contract (please contact your reseller).

More than one solution installed in the HP printer?
If you have more than one solution in a HP LaserJet Enterprise with Futuresmart 4.x firmware, BarDIMM must be the first solution that’s installed, otherwise the printer won’t run BarDIMM code after the reboot and no barcode will be printed. This problem did not appear with Futuresmart 3 and has been escalated to HP, the workaround is to ensure BarDIMM is installed first.

FAQ

Q: Can the BarDIMM Pro white USB stick for Futuresmart Modern printers also work on legacy Futuresmart 4 printers?
A: No, as HP Futuresmart printer models released before January 2021 have a different operating system not compatible with the Futuresmart Modern one. Legacy printers ‘Futursmart Classic” use the violet BarDIMM Pro USB  stick.
All the new Futuresmart Classic and Modern printers  are listed in the HP printers support table.
Futuresmart Modern printers use the JM30100Z part number.

Q: I update my HP FutureSmart 4 printer firmware to Futuresmart 5, will my current BarDIMM Pro 8.4A3 USB stick still work?
A: Yes, if your printer was compatible with FS4 and your BarDIMM Pro version is version 8.4A1 or greater, BarDIMM Pro will work on the same printer updated to FS5. If the BarDIMM Pro version is is earlier than 8.4A1, it is not compatible with the new security included from version 4.7.1 of the HP Futuresmart firmware. Updates are available to clients under support contract.

Q: I replace my old HP FS4 printer with a new HP FS5 printer model released in February 2021, can I just move the BarDIMM stick from the old to the new printer?
A: No, as HP Futuresmart printer models released from January 2021 have a new operating system not compatible with the previous one. Therefore a new BarDIMM Pro stick compatible with those printers is needed and its part number is JM30100Z.
All the new Futuresmart Modern printers  are listed in the HP printers support table.

Q: Is the BarDIMM Pro support contract covering the change from Futuresmart Classic to Futuresmart Modern printer?
A: No, as the support contract covers upgrades for binary-compatible operating system and failing USB sticks only. Futuresmart Modern printers also require a totally different USB stick with part number JM30100Z.

Q: What happens if I don’t use BarDIMM Pro 8.2 20171117 or newer with the HP FutureSmart 4 firmware?
A: BarDIMM Pro will be installed but will not license itself, “BarDIMM demo” will be printed across pages with barcodes

Q: Can BarDIMM Pro BarDIMM Pro 8.2 20171117 or newer for FutureSmart 4 also work on hp printers and MFP with FutureSmart 3 firmware?
A: Yes it does.

Q: I have some older printers, like the CM6040mfp and 4350, are they affected?
A: No they are not as they don’t accept any FutureSmart firmware

Q: Is the update also required for the external BarDIMM Box unit?
A: No, the upgrade is only necessary for the embedded version, delivered as a USB stick.

Q:  I am going to order some BarDIMM from my reseller to equip some recent HP printers, is there anything special to ask for?
A: Yes, you should ask to only get BarDIMM USB sticks with BarDIMM Pro 8.2 or newer. Resellers can contact us to know how to upgrade their USB sticks inventory.

Q: Can I get the update for free as I am under support contract for BarDIMM Pro?
A: Yes, clients under support contract and those who have purchased BarDIMM in the last 90 days get free update.

Copyright ©2022 Celiveo Pte Ltd - Using this site means you accept its terms and privacy policy